Noob question and mic

Hi :slight_smile:

My Rhasspy server is running (with virtuel env) \o/ but I don’t know which way to take it.

I’d like to know if everything works, especially my microphone (PS3 eye). How can I test it? How do I know if it records my voice well?

Rhasspy’s menus are very complex for a noob, eventually it will be to use it in connection with Jeedom (developped by @KiboOst) .

Thank you !

Have a look at: https://www.hackster.io/matrix-labs/rhasspy-voice-assistant-on-matrix-voice-and-matrix-creator-97f92e

They test the mic as well.

Thanks @Bozor for this link.

In my case, log doesn’t update when i speak, do i have to click on button ? Which one ?

When i restart Rhasspy, i have this log, i think it’s ok :

[INFO:332991220] quart.serving: 192.168.100.10:44458 GET /api/custom-words 1.1 200 0 48343
[INFO:332991218] quart.serving: 192.168.100.10:44460 GET /api/problems 1.1 200 291 20797
[DEBUG:332991207] InboxActor: -> stopped
[INFO:332991201] quart.serving: 192.168.100.10:44454 GET /api/unknown-words 1.1 200 2 16270
[INFO:332991183] quart.serving: 192.168.100.10:44452 GET /api/speakers 1.1 200 2 114277
[INFO:332991181] quart.serving: 192.168.100.10:44460 GET /api/microphones 1.1 200 107 112883
[INFO:332991170] quart.serving: 192.168.100.10:44454 GET /api/version 1.1 200 6 99613
[INFO:332991168] quart.serving: 192.168.100.10:44448 GET /api/profiles 1.1 200 144 33555
[DEBUG:332991163] InboxActor: -> stopped
[DEBUG:332991158] InboxActor: -> stopped
[INFO:332991153] quart.serving: 192.168.100.10:44458 GET /api/profile 1.1 200 6917 36642
[INFO:332991136] quart.serving: 192.168.100.10:44456 GET /api/profile 1.1 200 796 66742
[INFO:332991114] quart.serving: 192.168.100.10:44448 GET /api/profile 1.1 200 9386 14897
[INFO:332991092] quart.serving: 192.168.100.10:44448 GET /api/phonemes 1.1 200 1538 24542
[INFO:332991088] quart.serving: 192.168.100.10:44458 GET /api/slots 1.1 200 2 32215
[DEBUG:332991072] main: Loading phoneme examples from /root/rhasspy/profiles/fr/phoneme_examples.txt
[INFO:332991034] quart.serving: 192.168.100.10:44458 GET /api/sentences 1.1 200 501 8553
[INFO:332990935] quart.serving: 192.168.100.10:44462 GET /api/events/log 1.1 101 - 24976
[INFO:332990930] quart.serving: 192.168.100.10:44458 GET /img/logo.png 1.1 200 1924 10479

Did u click on wake and heard a short sound? If yes after the sound u can say your command.

In case you’re not hearing any sound after clicking on wake try another source out under the speaker section of the settings.

Actually, i have no speaker because Odroid C1 doesn’t have mini-jack. I have to buy this item : Odroid USB Audio Adapter

But, i think we can see something without speaker, don’t you think ?

dont have a usb headset or cheap usb soundcard lying around somewhere? =)

Maybe you could record a test wav into a directory you can access with your computer?

Also, Ps3 cam is pretty low by default - see this thread

You could run arecord <filename> to start a recording and save it to a file. Press Ctrl + C when you’re done and transfer the file to a computer with a connected speaker.

Thanks for your replies.

@NullEntity, each time, i have this error :

arecord: main:788: audio open error: Device or resource busy

If i change for PyAudio, i have the same error.

If i use arecord and test all device tagged working! i have the same error :frowning:

I don’t know what to do…

In rhasspy settings, uncheck “listen for wakeword on startup”
You can’t use wakeword and arecord simultaneously