No sound detection after 2.5 upgrade


I’ve just upgraded my Rhasspy Docker installation from 2.4.20 to 2.5.0, and it appears the audio detection has stopped working.

My setup is:

Rapsberry Pi 4B running Raspbian Buster
USB microphone
Rhasspy 2.5.0 under Docker
Porcupine wake word detection

When I say the wake word, I don’t get any errors in the log - just no response at all. If I use the microphone test button, then 3 debug messages are logged - again, though, no errors.

If I click the Wake Up button on the voice assistant home page, then I get the “Listening for command” pop-up, but it doesn’t respond to anything I say, and eventually times out. So I guess that no audio input is getting through to Rhasspy at all.

If I revert to 2.4.20, then the audio starts working again.

Can anyone suggest what might be happening, or how I might get some diagnostics?


Some additional info. I don’t know what to make of it, but 2.4 and 2.5 offer slightly different input devices:

Rhasspy 2.4 works with device 4. 2.5 doesn’t offer as many options. If I click the Test button at 2.5 it appears to be ok with 0 or 2, but neither choice actually delivers a wake word or any audio input.

Nothing in my setup outside Docker has changed.


Perhaps the same problem, which is described in this issue?:

Mine: No Beeps, no Wakeword, if I select external MQTT with non standard port.
Solution: I have installed an extra Mosquitto-Broker on the Rhasspy-Raspi and choose external MQTT, but with the IP-Adress of the Rhasspy

Ooh, you’re definitely onto something there - thank you. Rhasspy now responds if I click “Wake” on the voice assistant home page, and then say something.

So just the wake word not working now.


I’ve switched from Porcupine to Snowboy for the wake word detection, and all now seems to be well.

(I’m not sure whether to mark this as solved - I seem to have worked around the problems rather than solve them.)