No audio output, settings not saved

I’ve tried installing Rhasspy on both an RPI4 and an RPI2 in combination with a Jabra 410 mic/speaker combo. The mic works flawlessly when I use the ‘Hold to record’ button in the web interface.

However, when I set the wake word to Porcupine the first part of my sentence is cut off. I’m assuming this is because I do not get audio feedback. So I tried to enable text to speech (set to espeak and installed it) and Sounds to aplay. No sound is sent to the speaker so I tried changing the aplay output device to USB. Then I noticed that whatever change I make will not be stored.

So now I’m at a bit of a loss. Starting alsamixer allows me to change the card to Jabra but also alsamixer doesn’t save it’s settings. Supposedly ‘sudo alsactl store’ should store the settings but does not.

Any help would be appreciated.

Seems I didn’t explore this forum well enough. The solution was provided here:

My Rhasspy config now reads:

    "sounds": {
        "aplay": {
            "device": "dmix:CARD=USB,DEV=0"
    "wake": {
        "system": "porcupine"