Language question

I have 2 rpi 4 devices one is running home assistant os and the other one is running raspbian 32. For some weird reason the one running raspbian won’t work as a satellite in Dutch or in English but if I use it as a stand alone version (if it is my only rhasspy instance) then it will work in English but not in Dutch. I am pretty confused about this because why does the speaker microphone combo does work in English as standalone but not any other way. To clarify in Dutch the speaker microphone does get recognized and even get’s the “working” text but no wake sound and not a speaker. I have installed rhasspy now by using the armhf.deb file before I had a docker install but same problem. Maybe someone knows a fix but otherwise can I use 2 separate instances (one in Dutch and one in English) on the same mqtt broker?

Sounds like you have at least 3 different problems that you are mixing up.

How about you pick one problem, describe the situation (including providing configuration and logs), and stop changing the settings while we try to help.

Well the problem is quite simple. I have a raspberry pi 4 running raspbian os 32 bit with a usb attached speaker/microphone combination. Speaker/mic works. Rhasspy is installed as a satellite, language is Dutch. I followed your manual and everything works until I need to check the wake up function on the satellite. Microphone and speaker are recognized by rhasspy and get state working and then when I click wake up or speak text nothing happens it keeps loading and in the end gives a timeout error. That is the problem I have and my base station works fine. Edit: after last night doing nothing at least I get the error sound after clicking wake up.

Are you running from the command line on your satellite machine ? If so you can copy your configuration file and log here using the [ </> ] button (this keeps all the indentation and makes it easy to see which is the code).

  1. The configuration is in file ~/.config/rhasspy/profiles/nl/profile.json

  2. Try clicking [ Wake Up ] again and after the timeout

  3. If you are running rhasspy from the command line, simply copy and paste the last 40 lines of output.
    If you have setup rhasspy as a service, copy the last 40 lines from journalctl -u rhasspy.service

I wouldn’t put too much faith in the “(working!)” in the list of available devices. One of my satellites tells me that only the null device is working … which is simply not true.

My first thought is to try some of the other audio devices - particularly any starting “plughw:”

Will come back with code later. Rhasspy seems messed up now so will do a clean install first

Hi Don,

I am making progress currently I am using the plughw version and although I still can’t hear the wake up sound at least I can hear the sound when rhasspy doesn’t get the message. So I am assuming it is recording. Any ideas why I don’t hear the wake up beep?

Rhasspy configuration ? Log ?

It is incredibly hard to help you from vague descriptions

Sorry had a Tuya problem here that needed fixing first. Here is my config

    "handle": {
        "system": "hass"
    "home_assistant": {
        "access_token": "eyJhbGciOiJIUzred",
        "url": ""
    "intent": {
        "system": "hermes"
    "microphone": {
        "arecord": {
            "device": "hw:CARD=PowerConf,DEV=0"
        "system": "arecord"
    "mqtt": {
        "enabled": "true",
        "host": "",
        "password": "red",
        "site_id": "rhasspy2",
        "username": "mqtt-user"
    "sounds": {
        "aplay": {
            "device": "plughw:CARD=PowerConf,DEV=0"
        "system": "aplay"
    "speech_to_text": {
        "system": "hermes"
    "text_to_speech": {
        "system": "hermes"
    "wake": {
        "porcupine": {
            "keyword_path": "picovoice_raspberry-pi.ppn",
            "sensitivity": "0.7"
        "system": "porcupine"

And the log from the last hour

[DEBUG:2023-03-31 12:53:29,890] rhasspyserver_hermes: Sent 283 char(s) to websocket
[DEBUG:2023-03-31 12:53:29,889] rhasspyserver_hermes: Handling NluIntentNotRecognized (topic=hermes/nlu/intentNotRecognized, id=7d43187e-8903-4dc0-bd56-ee90e54f77f9)
[DEBUG:2023-03-31 12:53:29,889] rhasspyserver_hermes: <- NluIntentNotRecognized(input='', site_id='rhasspy2', id=None, custom_data='default', session_id='rhasspy2-default-2ebcdaae-264d-4e2b-b981-2da468798926')
[WARNING:2023-03-31 12:53:10,946] rhasspyserver_hermes: Dialogue management is disabled. ASR will NOT be automatically enabled.
[DEBUG:2023-03-31 12:53:10,945] rhasspyserver_hermes: <- HotwordDetected(model_id='default', model_version='', model_type='personal', current_sensitivity=1.0, site_id='rhasspy2', session_id=None, send_audio_captured=None, lang=None, custom_entities=None)
[DEBUG:2023-03-31 12:53:10,930] rhasspyserver_hermes: Waiting for intent (session_id=None)
[DEBUG:2023-03-31 12:53:10,929] rhasspyserver_hermes: Publishing 200 bytes(s) to hermes/hotword/default/detected
[DEBUG:2023-03-31 12:53:10,929] rhasspyserver_hermes: -> HotwordDetected(model_id='default', model_version='', model_type='personal', current_sensitivity=1.0, site_id='rhasspy2', session_id=None, send_audio_captured=None, lang=None, custom_entities=None)

Hope this helps.

My satellite configuration is the same … except for using the UDP option in Microphone and Wake sections (which i understand to be more efficient but not affect the operation) … and that I am using the porcupine keywords file (porcupine_raspberry-pi.ppn).

If you are hearing the Error sound but not the Wake sound, please check the “Sounds” block on the Setting page. Possibly you have accidentally deleted the value for Wake WAV or the beep_hi.wav file ? My Sounds looks like

As for your log file…

I tried changing my satellite to the picovoice keywords file you are using … but “porcupine” wasn’t recognised; and I couldn’t find in the documentation what keyword to speak. It looked to me as though picovoice might be a tool designed for making custom keywords. I noticed also that your HotwordDetected log entries include “model_id=‘default’” whereas mine contain a (very long) path and file name for “model_id”.

I have changed mine back to Porcupine keyword, Restarted system (to make sure it really is changed) and “porcupine” is working again

I suggest you change your Keywords file to Porcupine and restart Rhasspy. Note that it may take several minutes to change things in the background before the satellite is ready to listen for voice commands.

For comparison, this is the satellite’s Rhasspy log I am getting:

[DEBUG:2023-04-01 15:23:19,637] rhasspyserver_hermes: <- NluIntent(input='what is the time', intent=Intent(intent_name='GetTime', confidence_score=1.0), site_id='sat-1', id=None, slots=[], session_id='sat-1-porcupine_raspberry-pi-296d897e-4cc7-4746-bac6-3bcfd329b929', custom_data='porcupine_raspberry-pi', asr_tokens=[[AsrToken(value='what', confidence=1.0, range_start=0, range_end=4, time=None), AsrToken(value='is', confidence=1.0, range_start=5, range_end=7, time=None), AsrToken(value='the', confidence=1.0, range_start=8, range_end=11, time=None), AsrToken(value='time', confidence=1.0, range_start=12, range_end=16, time=None)]], asr_confidence=1.0, raw_input='what is the time', wakeword_id='porcupine_raspberry-pi', lang=None)
[WARNING:2023-04-01 15:23:15,755] rhasspyserver_hermes: Dialogue management is disabled. ASR will NOT be automatically enabled.
[DEBUG:2023-04-01 15:23:15,750] rhasspyserver_hermes: <- HotwordDetected(model_id='/usr/lib/rhasspy/usr/local/lib/python3.7/site-packages/pvporcupine/resources/keyword_files/raspberry-pi/porcupine_raspberry-pi.ppn', model_version='', model_type='personal', current_sensitivity=0.3, site_id='sat-1', session_id=None, send_audio_captured=None, lang=None, custom_entities=None)
[DEBUG:2023-04-01 15:23:12,447] rhasspyserver_hermes: <- NluIntentNotRecognized(input='', site_id='sat-1', id=None, custom_data=None, session_id='sat-1-porcupine_raspberry-pi-8075c8a9-3137-47b8-a174-6980d9d08ea7')

Well I have tried that and no change. When I checked the docs it seemed that porcupine doessn’t work with the Dutch language so maybe there is an error there?

You are correct, Dutch is not listed as supported by Porcupine. Sorry, my bad !
I have trying to get your system working using English; then when we change one thing, it must be the cause of any problem.

Looking at the home page of the Rhasspy documentation it looks as though there are only a couple of options which support Dutch language … though it’s quite possible the documentation is out-of-date.

* Dutch (Nederlands, nl)

where Kaldi is a Speech-to-text module (which will run on your Rhasspy base machine); and Pocketsphinx is an option for Wake word on the satellite.

If you change Wake Word to Pocketsphinx there are links to some documentation.

Will give that a go, thanks! Might end up in English anyway or German. HA functions properly in Dutch but for most people it’s not an interesting language to add. Will report back after the changes thanks for your help so far!

Don I got these kaldi training errors again and just got tired of these issues. Now I am trying a new install in English to see if that fixes the problems. Hopefully HA with year of the voice will have a dutch working version one day or rhasspy3 will work properly in Dutch. For now I will try to get the English version working. Thanks for all your help

Sorry I didn’t help :frowning:

Michael (@synesthesiam) seems especially motivated for Rhasspy to support as many languages as possible, and I’m fairly sure I have seen Dutch mentioned in discussions here before. If you haven’t already, please do a search for “Dutch”.

Unfortunately i think he’s totally focussed on Rhasspy v3 at the moment - so keep an eye on that thread.

Hi Don,

I have an update for you my base station with home assistant in dutch is working fine. On my satellite which is a raspberry pi 4 as well I am running dietpi with the deb install in English. Funny thing is because the base is in Dutch when I type a Dutch sentence it does what it needs to do. Still pulling my hair out why the wake word isn’t functioning on the satellite though. I have tried switching the anker micr/speakers. The one from the satellite does function in the rhasspy add-on. I must be missing something on the satellite because both speakers function fine through the add-on. Work in progress haha