Killed my docker container


I messed around with my docker container and stopped it and now when I run the command I initially started it with I get this:

pi@rhasspy:~ $ docker run -d -p 12101:12101       --name rhasspy       --restart unless-stopped       -v "$HOME/.config/rhasspy/profiles:/profiles"       -v "/etc/localtime:/etc/localtime:ro"       --device /dev/snd:/dev/snd       rhasspy/rhasspy       --user-profiles /profiles       --profile de
docker: Error response from daemon: Conflict. The container name "/rhasspy" is already in use by container "9e0caf551afe41fd4d41d1a90677e7ce2ae3c23e329a4201a01f8a0f53975e14". You have to remove (or rename) that container to be able to reuse that name.
See 'docker run --help'.

Rebootet and tried again but still the same. Any hint?

docker start rhasspy

docker run is for creating a container from an image. Once the container is created with a —name another container with the same name cannot be created. You can however start the existing container with docker start <id or name of the container>.

If you want to create a new container (with different options, volumes, port bindings, etc.) with the same name, you will first have to remove the existing one with docker stop <name> and docker rm <name> before issuing a new docker run command.

Hope this helps.


run docker ps to see all id of your existing containers and pick the rhasspy container.

afterwards you can restart, start or stop the container using: docker start CONTAINERID
instead of start use the above possibilities.

1 Like

Thanks guys but it just started working again. :smiley:

I don’t know what happened, but now I can’t reach it anymore again. I was working with sentences and training and when I tried to test a new intent, the website timed out,

The container seems to be running and I can SSH into the Pi, however the website is not reachable on http://IP:12101.

pi@rhasspy:~ $ docker ps
CONTAINER ID        IMAGE               COMMAND                  CREATED             STATUS              PORTS                      NAMES
9e0caf551afe        rhasspy/rhasspy     "bash /usr/bin/rhass…"   37 hours ago        Up 15 minutes>12101/tcp   rhasspy

No idea how to troubleshoot that. Should really get some more docker knowledge.

It gets even more curious: When I say Snowboy, I get a beep so something is running. However Node_RED is not able to connect anymore, as well as my web browser.

SSH still possible…

I got it fixed by power cycling the Pi, while a reboot did not help before.