Installation issue with deepspeech on RPi 4 armv7l

Hi, newbie here!

I’m trying to install Rhasspy using virtual environment on my Raspberry Pi 4. There seems to be an incompatibility with deepspeech. I get this on make install step.

ERROR: Could not find a version that satisfies the requirement deepspeech==0.9.3 (from rhasspy==2.5.11) (from versions: none)
ERROR: No matching distribution found for deepspeech==0.9.3 (from rhasspy==2.5.11)

How can I remove dependency to deepspeech? I should be able to install without it right? I tried removing the line deepspeech==0.9.3 from requirements.txt but still getting the same.

Any other workarounds also could help.

OK, averted the issue by using --disable-deepspeech on configure. I am also switching to a 64bit OS. I believe that would solve the similar new issue that’s created by onnxruntime.

1 Like