How do I get Home Assistant Entities into Rhasspy?

I am a newbie who is really stuck!
I have just set up the following:

  • Rhasspy Base using HA Addon
  • Rhasspy Satellite on PI4 using docker installation

Base & Satellite communicate fine, If I use the wake word and ask the time I get a response.

Now I want to properly integrate Home Assistant. I have found the ‘slot_programs’ under examples/Home Assistant/profiles on the rhasspy github.

This looks like a great solution but when I run the script, nothing seems to happen

My HA setup uses SSL through LetsEncrypt using the HA add-on. The note in the code says: # NOTE: This script will not currently work with a custom HTTPS certificate.
Look at the home_assistant.pem_file and home_assistant.key_file profile settings if you want to add it.
I don’t know what this means or what I need to do to get the script to bring my HA entities into Rhasspy.

Has anyone found a way to make this work? Any help or suggestions much appreciated :slight_smile:


The slot program needs the home assistant settings in your Rhasspy config to be filled in. Host, api key, etc… Once that is in there you should be able to create a variable in your sentences file that equals the slot program name.

FYI, shameless plug here, I created an enhanced slot program that can get both entities names and entity aliases in a single list. You can check it out here: New slot program for Home Assistant entities with aliases

Thank you for your help. I’d certainly be interested to look at your enhanced slot program :slight_smile:
However, I am working at (beyond!) the limits of my knowledge. I still can’t get things working. Here are screenshots of my configs in both the HA Addon and in Rhasspy:

I think I have the HA setting in Rhasspy config but I’m not sure about settings in the HA Rhasspy Add-on config. It may be a daft question but I don’t know what to put in http_host? Could you give an example? Also under certfile and keyfile, these are the 2 files from LetsEncrypt. They are in the /ssl/ folder on my HA installation but if I try to include the path with the filename, it throws an error when I try to save the config. Like I say, the answers may be simple but I just don’t know :slight_smile:


I don’t use the HA addon (I run Rhasspy standalone in a base/satellite setup) but I will do my best.

Question, is this the junior addon or the full one?

For host, since this is running on your HA server you can set the same hostname as your HA server. There are some more advanced setups where you can have it use a different name but for now the HA hostname should work fine.

Also, when you get a chance, send a screenshot of your sentences file in Rhasspy. Let’s see how rhat is setup.


I’m running the full Rhasspy Assistant Add on and a separate Pi4 Satellite

I now find I can run Rhasspy will SSL switched on but http_root is blank.

The slot program does not seem to work still. I attach sentences screenshots. I have 2 files

…another thing. I tried running your enhanced slots program. It didn’t appear to throw any errors but when I tried to retrain Rhasspy, it could find no entities. Don’t know whether this helps?