How do erase Rasspy from Hassio COMPLETELY

Dear All,

I am using Rhasspy add on in Home Assistant and have a problem - I might have done something to the setup and now training of the simplest test intent goes forever no metter what I do. I checked, when loading different language profile, training goes extremely fast. I am trying to delete add-on to reinstall it back, but it stores the config and history data and restores whole thing into last state after I reinstall the add-on. How to erase Rhaspy completely from HA, so I would start from scratch next time I install it back?

Please help.

Below is the log of Rhasspy. Maybe someone knows why training goes for eternity now?:

[DEBUG:2021-02-04 23:28:10,102] rhasspyserver_hermes: Publishing 361 bytes(s) to rhasspy/nlu//train
[DEBUG:2021-02-04 23:28:10,102] rhasspyserver_hermes: -> NluTrain
[DEBUG:2021-02-04 23:28:10,101] rhasspyserver_hermes: Publishing 361 bytes(s) to rhasspy/asr//train
[DEBUG:2021-02-04 23:28:10,101] rhasspyserver_hermes: -> AsrTrain
[DEBUG:2021-02-04 23:28:10,101] rhasspyserver_hermes: Subscribed to hermes/error/nlu
[DEBUG:2021-02-04 23:28:10,101] rhasspyserver_hermes: Subscribed to rhasspy/nlu//trainSuccess
[DEBUG:2021-02-04 23:28:10,100] rhasspyserver_hermes: Subscribed to hermes/error/asr
[DEBUG:2021-02-04 23:28:10,100] rhasspyserver_hermes: Subscribed to rhasspy/asr//trainSuccess
[DEBUG:2021-02-04 23:28:10,100] rhasspyserver_hermes: Finished writing /share/rhasspy/profiles/ru/intent_graph.pickle.gz
[DEBUG:2021-02-04 23:28:10,100] rhasspyserver_hermes: Writing /share/rhasspy/profiles/ru/intent_graph.pickle.gz
[DEBUG:2021-02-04 23:28:10,099] rhasspynlu.ini_jsgf: Loaded ini file
[DEBUG:2021-02-04 23:28:10,099] rhasspyserver_hermes: Generating intent graph
[DEBUG:2021-02-04 23:28:10,098] rhasspyserver_hermes: Loading sentences from [PosixPath('/share/rhasspy/profiles/ru/sentences.ini')]
[INFO:2021-02-04 23:28:10,098] rhasspyserver_hermes: Starting training

Install samba addon if you have not done so already.
Then remove the rhasspy from the /share folder.

Thanks a lot for you help, I shall try it!

But I think I have found the cause:

I made blank the ‘siteId’ field at the top of the /settings page and this makes the training in my language go to eternity - is it a BUG? How is ‘siteId’ field related to the training process? When I put any sequence of characters into this field - training is completed in 2 seconds! Why?