How can I backup entire profile

first of all, thanks for this great voice assistant.
Although i have a lot more to learn, I managed to build my voice system in only a few days.
I use the server/client setup with
How can i backup my entire profile / setup: prefs, slots, sentences etc?

With v2.5 there a button for that in the interface.
On v2.4 Check in /home/user/.config/rhasspy/Lang/profile
Lang being en, fr, de etc.
Then backup sentences.ini profile.json and intents and slots folders.

Then you have it all.

I’m on 2.5.
Where can I locate this button?

Go to the Settings page, there you’ll find a green Backup Profile button at the top.

Don’t forget any custom words :wink:

1 Like

Hi All,
As already mentioned above, thanks for this good voice assistant. I would like to add the following for this uncompleted topics :wink: :slight_smile: Yes easy to backup profiles and add custom wake word with backup profile bottom but how to restore ???.
because, i rebuilt a new rhasspy from scratch ( without docker to check system resource decrase regarding wakeword consumption) and I would like to restore all config setting without missing and location files
An idea ?

Hi @berniland, you’re welcome :slight_smile:

It should be possible to just copy your whole profile directory over. Since you were using Docker previously, you will probably need to do a chown -R $(id -u):$(id -g) /path/to/profile to fix the permissions.

Make sure to re-train, of course, since there are a few auto-generated files that will have hard-coded paths in them.

Hi synesthesiam, thanks for you reply. finally,I used backup profile tgz, extract from my pc and scp to the right folder ~/.config/rhasspy/profiles/fr without chown needed. I did scp for my raven wake work folder to ~/.config/rhasspy/profiles/fr/raven as well.
that all.
I would like to add as well, my initial CPU raising issues and poor rhasspy working is fix.
CPU never up more 100% ( 4 CPU) and wakeword work fine. I don’t kknow if root cause was really link with docker building or consumption. I just did the following installation step on lastest raspios :
sudo apt-get update && sudo apt-get upgrade -y
sudo apt install /home/pi/rhasspy_2.5.9_armhf.deb
restore backup profile and did alsamixer to set mic and player
finallylaunched “rhasspy --profile fr” as service and that all
it’s remain some false positive but perhaps because the wakeword itself “macabane” :wink:
good day all