Help with Mycroft-precise. Can´t find "precise" folder

Hi everyone
I´ve trained a new wake word with Mycroft-precise but I can´t find the “precise” folder where to store my .pb and .pb.params files in my profile directory as explained on the Rhasspy docs.
Is it supposed to create the new folder automatically after changing setting on the web interface?
I created the folder myself but didn´t work.
Also, I copied the files into [rhasspy-wake-precise-hermes] which is where the other sample files are located (hey-mycroft 2/ sheila -en / marvin / athena etc…) but my files are not being loaded in the drop down menu in the setting page of the web interface under: Available Models. (Yes, I refreshed and rebooted and all that…)
Only Hey-Mycroft 2 works. Editing the profile.json file manually didn´t work either.
I´m running Rhasspy 2.5.7 with docker on PI 4 , everything else works like a charm, not sure what I´m missing here, could it be a ${RHASSPY_BASE_DIR} issue maybe??
Any help would be much appreciated.
Thanks in advance folks!

As i set my wakeword up with precise a while ago i dont remeber if the precise folder was created by rhasspy or if i manually created it. I just tested if it still works with rhasspy 2.5.7. I am also running it with docker on a pi4. At what location did you manually create the precise folder?

Hi moqart
Thanks for your message.
I´ve manually created a folder named precise in my profile directory: /home/pi/.config/rhasspy/profiles/en/precise and moved the .pb and pb.params in there.
I guess my question is how do I get my files loaded onto the “Available Models” drop down menu in settings…?
Thanks again

I just have the model files in that folder and they get detected automatically after hitting the refresh button next to the selection.

Did you select mycroft precise then hit save settings and let it restart and then tried refreshing the hotwords. If you dont save the selected hotword service first you will get the results for the previously selected one?

Yes I did. I even removed the docker image and pull it back again, then select Mycroft and save then refresh and nothing. This is how my profile.json looks like, how´s yours??

“dialogue”: {
“system”: “rhasspy”
“intent”: {
“system”: “fsticuffs”
“microphone”: {
“system”: “pyaudio”
“sounds”: {
“system”: “aplay”
“speech_to_text”: {
“system”: “kaldi”
“text_to_speech”: {
“marytts”: {
“url”: “”,
“voice”: “dfki-spike-hsmm”
“system”: “marytts”
“wake”: {
“system”: “precise”

sorry for all the question…

This is how my profile.json looks.

    "command": {
        "webrtcvad": {
            "vad_mode": "2"
    "dialogue": {
        "satellite_site_ids": "default,satelite",
        "system": "rhasspy"
    "intent": {
        "satellite_site_ids": "default,satelite",
        "system": "fsticuffs"
    "microphone": {
        "pyaudio": {
            "device": "0",
            "siteId": "default",
            "udp_audio_host": "",
            "udp_audio_port": "12102"
        "system": "pyaudio"
    "mqtt": {
        "enabled": "true"
    "sounds": {
        "aplay": {
            "device": "sysdefault:CARD=seeed2micvoicec"
        "error": "",
        "recorded": "",
        "system": "aplay",
        "wake": ""
    "speech_to_text": {
        "satellite_site_ids": "default,satelite",
        "system": "kaldi"
    "text_to_speech": {
        "picotts": {
            "language": "de-DE"
        "satellite_site_ids": "default,satelite",
        "system": "picotts"
    "wake": {
        "pocketsphinx": {
            "threshold": 9.999999999999999e-33
        "porcupine": {
            "udp_audio_port": ""
        "precise": {
            "chunk_size": "2048",
            "model": "computer8.pb",
            "sensitivity": "0.7",
            "trigger_level": "3",
            "udp_audio": "12102",
            "udp_audio_port": "12102"
        "snowboy": {
            "audio_gain": "1.5",
            "sensitivity": "0.9",
            "udp_audio_port": "12102"
        "system": "precise"

It contains settings from the other wakeword systems too because i tried those before creating a custom wakeword for precise. I am getting good recognition and only few false activations when talking a lot in the room.

Hi moqart
Thanks for all your help!!!
I got it working but not sure what was it, after reinstalling the docker images it didn´t create the folder automatically but I added it manually again and this time it worked !! I can see my model on the list now.
Just need to train it a bit more as I get a few false positives and false negatives too.

Thank you again, I was a bit lost with this issue…

1 Like

Getting the false positives down is the hard part (if you use a regular word like computer).

I´m using a made up word “elupy” but also trying a few different ones… see how it goes.
It works better if you record multiple voices I think, as in different people I mean.
Thanks again for your time. big help

It can also have some advantages if it reacts better to your own voice depending on what you use it for.
How many recordings are you using to train your model ?

f you are using a made up word you have it easier using speech data for your random audio that does not contain your wakeword. Mozilla common voice could be a good source of audio to reduce false activations during talking .

I´m using about 20 WAKE-WORD and around 200 NOT-WAKE-WORD from pdsounds_march2009 file suggested in Mycroft-precise GitHub plus a few NOT-WAKE-WORD I recorded myself.
I will try Mozilla common voice, good tip.

Getting the false negatives down just requires more positive examples so you cover all the variations better. Only huge issue was when my voice sounded different after talking too much and abit too loud (not sure on the correct english word). Then i was nearly unable to activate the wakeword.

it’s a long and difficult process, no doubt about that.
I will keep testing