Help with Kinect

Hi all !!
I’m trying to make the kinect microphones to work on a raspberry install. Anybody had success with that ?

I can succesfully record audi with this arecord command : " arecord -D hw:1,0 -f S32_LE -r 16000 -c 4 test.wav"

So I tried setting up arecord in rhasspy, but read the defaut arecord settings where quite different, and the kinect won’t work unless i have those precise option selected.

Is there any way to customise arecord defaut rhasspy options ?

Thanks for your help :slight_smile:

Try to use plughw:1,0 as the input device using arecord.

Thanks for the reply, but just tried with no luck…

Do you know if there’s a way to better debug what’s happening ? the interface log are quite empty…

So I managed to get the kinect as default arecord device, so now no need for specific options to test record a wave file… but still nothing on the rhasspy side configured with arecord :frowning:

Here is the log but it does not help a lot i think :

[ERROR:2020-06-14 07:35:21,133] rhasspyserver_hermes:
Traceback (most recent call last):
File “/usr/lib/rhasspy/lib/python3.7/site-packages/quart/”, line 1821, in full_dispatch_request
result = await self.dispatch_request(request_context)
File “/usr/lib/rhasspy/lib/python3.7/site-packages/quart/”, line 1869, in dispatch_request
return await handler(**request_.view_args)
File “/usr/lib/rhasspy/lib/python3.7/site-packages/rhasspyserver_hermes/”, line 810, in api_listen_for_command
handle_captured(), messages, message_types
File “/usr/lib/rhasspy/lib/python3.7/site-packages/rhasspyserver_hermes/”, line 898, in publish_wait
result_awaitable, timeout=timeout_seconds
File “/usr/lib/python3.7/asyncio/”, line 449, in wait_for
raise futures.TimeoutError()
[DEBUG:2020-06-14 07:34:51,130] rhasspyserver_hermes: Publishing 166 bytes(s) to hermes/asr/startListening
[DEBUG:2020-06-14 07:34:51,128] rhasspyserver_hermes: -> AsrStartListening(site_id=‘default’, session_id=‘926ba93a-8dd3-4c2e-9748-cbb865786a75’, stop_on_silence=True, send_audio_captured=True, wakeword_id=None, intent_filter=None)
[DEBUG:2020-06-14 07:34:51,125] rhasspyserver_hermes: Subscribed to hermes/error/asr
[DEBUG:2020-06-14 07:34:51,124] rhasspyserver_hermes: Waiting for transcription (session_id=926ba93a-8dd3-4c2e-9748-cbb865786a75)

In the Settings page, can you use the “Test” button under arecord settings and see if it says your mic is “working”?

So I made some improvement, I started again from scratch, used Ubuntu mate as OS, and added pulseaudio to get it to work :slight_smile:
Now trying to improve the sound capture cause I have to be really close to the speaker to get it to work, which wasn’t the case with other voice assistant I tried…

And to answer your question, the test button doesn’t work (or I can’t see any notification), but still it works to capture sound…

1 Like