Help on Intent Handling remote HTTP


I am trying to send a command to a PHP Server in my network as part of intent-handling. I entered the Remote URL under Remote HTTP in the settings and I see on my php server side, that Rhasspy accesses this URL. However - it dos not post any JSON to that remote HTTP endpoint - it only opens the pure URL I have given.

I am currently testing it with the “What is the temperature” example.

[DEBUG:2021-01-22 15:36:26,216] rhasspyserver_hermes: Handling NluIntent (topic=hermes/intent/GetTemperature, id=129d1218-5cc9-49f5-a289-d4070a3ee0fc)
[DEBUG:2021-01-22 15:36:26,215] rhasspyserver_hermes: <- NluIntent(input=‘wie ist die temperatur’, intent=Intent(intent_name=‘GetTemperature’, confidence_score=1.0), site_id=‘default’, id=‘5e24d7b3-84bc-47c4-bf70-c74085001b2a’, slots=[], session_id=‘5e24d7b3-84bc-47c4-bf70-c74085001b2a’, custom_data=None, asr_tokens=[[AsrToken(value=‘wie’, confidence=1.0, range_start=0, range_end=3, time=None), AsrToken(value=‘ist’, confidence=1.0, range_start=4, range_end=7, time=None), AsrToken(value=‘die’, confidence=1.0, range_start=8, range_end=11, time=None), AsrToken(value=‘temperatur’, confidence=1.0, range_start=12, range_end=22, time=None)]], asr_confidence=None, raw_input=‘wie ist die temperatur’, wakeword_id=None, lang=None)

Any help where and how I can configure that it should post really the JSON with the intend data would be really good.



I am having the same issue, have you got the solution.

If you’re testing with the Rhasspy web interface, make sure you check the “Handle” checkbox. In the normal wake/command flow it should happen automatically.