Help Needed with Matrix Voice Setup

I’m looking for a bit of guidance with my setup as I have been doing trial and error with no luck.

  • Hassio running on Pi3 with Mosquitto broker enabled and configured pr. instructions in the add on.
  • Matrix Voice running Matrix-Voice-ESP32-MQTT-Audio-Streamer standalone. Connected to Wifi with blue led ring. Mqtt server IP points to the IP of the Pi3 with username and pass set. I can see the MatrixVoiceAudio in the broker log.
  • Rhasspy running as Hassio addon. I have enabled MQTT and set the host to the IP of the Pi3 running Hassio along with the user name/pass. Site ID is set to matrixvoice.

The log in Rhasspy is full of

  [DEBUG:349369] HermesMqtt: Reconnecting in 5 second(s)
  [ERROR:349367] HermesMqtt: connecting
  Traceback (most recent call last):
  File "/usr/share/rhasspy/rhasspy/", line 129, in do_connect
  ret = self.client.connect(, self.port)
  AttributeError: 'NoneType' object has no attribute 'connect'

Any inputs to point me in the right direction?

Is this the same issue? A restart of Rhasspy fixed it for another user.

I could have sworn I have restarted a number of times. I did disable the mic and restarted and reenabled. Now the error is gone and I was able to use the Matrix mic for the first time triggering a flow in Node red :grinning:

Now on to figuring out the whole hotword thing, led animations etc.

Thanks @koan

There is already a very basis taks called everloopAnimation in the streamer.
It is not started however (commented out), but if you can make something nice with that 'd be great :slight_smile:

I created that streamer in case you weren’t aware :slight_smile:

Sounds great. I will tinker with it a bit later. I’m not a coder at all - just good with Google. I bought the Matrix Voice kit the other day and finally got your streamer working. Just now I got it to trigger with “Hey Pico” hotword and then ran a flow in Node Red for my lights. Feels like magic!! Thank you guys for creating all of this.

I have a further issue but not sure where to pinpoint:

I’m using a custom hotword with Snowboy and I can trigger to the Matrix Voice from around 5 meters or so without having to shout.

However, I can never get an intent to trigger unless I’m less than 1 meter away from the Matrix.

So the question is if there is a quality issue with the audio coming from the Matrix or similar? Basically I’m not sure what else I can adjust at the moment.

I’m using the basic sentences provided be default in Rhasspy so nothing too fancy.

Ok, that is strange. I do not have that problem.
It might be an audio qualitiy issue, but hotword gets detected so that does not match.
Have you tried various intent recognition systems? Is there anything transcribed in the logging?