HA, no ReSpeaker in the house

Sometimes in the Home Assistant add-on Rhasspy Assistant the Seeed Respeaker is not there? It drops out.
It is not possible to select it anymore. In the configuration input output select box. Only Default.

When you go to config/hardware in HA All hardware the Seeed respeaker is present.
But only when you reboot the whole system then it is possible to select the ReSpeaker again.
Restarting the add-on does not solve it.

So is there a way to manually input the device id string. In for instance yaml.

Hi Franboos and welcome.

Just to clarify …

  1. Which Home Assistant installation did you do (HA OS, Debian, or one of the other options ?)
  2. Do you have the reSpeaker connected to the same machine which is running Home Assistant ?
  3. Does your reSpeaker connect by USB, or is it one of the Raspberry Pi HATs ?

Thanks for the reply,

HA is running as an ova. A virtual machine.
ReSpeaker is connected via usb on the same physical machine.

There is also a usb zigbee dongle connected. On another usb port.
This one is always there does not drop out.
And you can add the device id string in the config file.

Also included screenshot’s. Oops only one image is allowed to upload.
So merged 3 png’s in one. Hopefully it is viewable.