Getting started with Pi Zero as satellite

Have had some early success with this el cheapo respeaker knock-off USB Conference Microphone w/Speaker 360° Omnidirectional for PC Laptop | eBay connected to a Raspi Pi Zero running 2.5.11. Rhasspy was installed from .deb file.
The intention is for this to be a satellite (replace a GH Mini) to my HA on a Pi4 with the satellite device wifi connected and located in a living room.
During testing I am getting some behaviour that may be due to Pi Zero limitations. Looking for some confirmation of this.
After speech there is a long wait before a Timeout is signalled, Intent is recognised but then it goes off screen and is Replaced by “No intent recognized”. Other times the Intent remains recognised.

Is this expected behaviour? Seems different to YT demo.

Is the duration of the listening period configurable?

Sometimes I get ‘turn on the the light’ instead of what it should be.
The next step is going to be transforming those Intents into action on the Pi4 running the Rhasspy Integration.

Ok found Voice Command Settings. I have


but after reducing Maximum Duration to 10 secs I still get a long period and then timeout. I usually end up cancelling the Listening Command but shouldn’t need to(?). Do I have something not set correctly?

The long timeout suggests that the microphones are picking up noise and Rhasspy can not detect the silence area then.
Try to record a sound and open it up in a sound edtior, where you can hear the different channels.

I also have a Pi Zero running as a rhasspy satellite … but mine is only doing the audio recording and playing plus wakeword detection. It is noticably slower than my Pi 3A and Pi 3B satellites running the same configuration, … and personally if I make more satellites in future I will use Pi Zero 2 or Pi 3A units.

I have a RasPi 4B which is running Home Assistant with MQTT, Rhasspy and node-RED add-ons. The Pi Zero calls Rhasspy on the Pi 4 to do the compute-intensive processing (speech-to-text, intent recognition and text-to-speech modules), and this seems to be working well.

As for your symptoms, I have the same Voice Command Settings, though in my case that’s on the RasPi 4. If you are also doing the Speech-to-text and Intent Recognition on the Pi Zero … maybe the Zero’s processor is taking too long ? You mention you already have a Pi4 with Home Assistant, so it might be worth giving the HA Rhasspy add-on a try for the more processor-intensive tasks.

I agree with WallyDW. The speech-to-text should be recording until it hears a period of silence, and it’s the silence which times out. If the microphone is hearing noise it will listen longer. I find this quite noticable in my living room when the TV is on.

I am stumped by the Intent being recognised, then replaced with “No intent recognised”. Which Intent Recognition module are you using ?

Robb, I am curious about your cheap conference device, since my experience with the reSpeaker HATs is not up to my expectations. I suspect though, that all conference speakers are designed to be used in an otherwise quiet environment - and the background noise is my main problem.

Thanks both for your comments.
I think it is likely that the sensitivity to background noise is at the core of the issue I am having so Rhasspy is having trouble detecting silence. I will need to devote some time to understanding the energy settings and other parameters available.
My use case for the satellite is similar to yours @donburch. Just wanting it for voice commands and audio notifications. I used the PiZ because I had one that was looking for a project so hopefully it does the job.
I will be on the road for a few weeks so unable to do any dev work. I would be interested in how you proceeded with the Pi Zero to HA comms. Did you use Events or Intents? Did you need to use Snips? Have only just started reading up on the needs in this area.
Cheers