Fresh install, sentences.ini, Docker version


Just started with Rhasspy (< 1 week!) - still waiting for a microphone, but been playing with Rhasspy/Node Red and find it excellent.

This morning I decided to do a fresh Docker install from scratch, just to make sure that I had everything correct and not made any corruptions where I have been blundering around.

Anyway, I found that sentences.ini was missing (tried the rebuiled twice), so I made my own file up. Not sure if this is because of the version update to 2.4.14, but for me, that file was an excellent place to get some examples of the format to be used, and was sorely missed.

I am now not sure if I have 2.4.13, or seeing that 2.4.14 has been announced, if it is in fact 2.4.14 (in view of the missing sentences.ini) with 2.4.13 showing as the version. If I am still on 2.4.13, how do you get an update through Docker (first time I have used it!).

I started out with a great amount of apprehension, but now love it. Nothing to be scared of yet. I have my Node Red Flow eady to start receiving the STT output, just waiting to see what format that comes out in and then I am ready to go!! (Rhasspy/Node Red/ Opto22 PAC R1 controller)

Thanks for a great Toolkit, you have done a wonderful job.


Update the container image:

docker pull synesthesiam/rhasspy-server:latest

Stop the current container (substitute the name by what it’s called in your setup, you can look it up with docker ps):

docker stop rhasspy-server

Remove the current container:

docker rm rhasspy-server

And then you can start/run the Docker container again, which will use the newly downloaded version now.

1 Like

Thank you @koan for your prompt response.

Not 100% sure that it did what was intended - mainly due to my NOOB experience of Docker, not your instructions.

After using docker ps
rhasspy-server and rhasspy-server:latest do not work - no such container (these were obtained using the IMAGE name - which I do expect to be incorrect).

But using the Container ID # does appear to work with the update being extremely quick with a long hex number being the result. Same with using the ‘NAMES’ ID

After the stop, the Rhasspy web page (:12101) was not available, after the rm I tried starting the container, but was told it that there was ‘no such container’. After running the Docker container again using both the Container ID and the NAME, the server started again.

However, revison of Rhasspy still displays as 2.4.13.

To me it does seem that what I did worked, but the Revision Number is not what I expect so it leads me to question what I have done.

Please don’t take this as any criticism of your instructions, I am just unsure…

Sorry, I wasn’t clear: you have to use the name in the NAMES column of your Rhasspy container for the docker stop and docker rm commands.

But starting the container again with the command in Rhasspy’s documentation should work, weird that you get ‘no such container’.

I just checked: you have done nothing wrong. The current version in Rhasspy’s source is stil shown as 2.4.13 :slight_smile: So @synesthesiam just forgot to update it.

1 Like

I would have thought the rm removed the container so I was not surprised I got yhe no such container message - what I expected and was using it to fault find.

Phew!! JUst had doubts I was doing it wrong!!

I suspected it was .14 as the settings page had changes and (possibly) sentences.ini was missing.

Thank you again.

Just pushed a fix for the sentences.ini issue and bumped the version. I had done it locally, but must have gotten distracted and forgot to push!

Thank you synesthesiam.

As I said, much respect to you for doing this whole project.

1 Like