Failure training

I am getting on error on the training of the model.

[ERROR:2022-02-22 02:46:39,782] rhasspyserver_hermes: AsrError(error="Command '['fstcompile', '--isymbols=/profiles/en/kaldi/model/data/lang/words.txt', '--osymbols=/profiles/en/kaldi/model/data/lang/words.txt', '--keep_isymbols=false', '--keep_osymbols=false', '/profiles/en/kaldi/language_model.txt', '/profiles/en/kaldi/model/data/lang/G.fst.unsorted']' returned non-zero exit status 1.", site_id='base', context=None, session_id='dcd46625-743c-4e2a-9b3f-78240ef99ce4')
[ERROR:2022-02-22 02:46:39,783] rhasspyserver_hermes: Command '['fstcompile', '--isymbols=/profiles/en/kaldi/model/data/lang/words.txt', '--osymbols=/profiles/en/kaldi/model/data/lang/words.txt', '--keep_isymbols=false', '--keep_osymbols=false', '/profiles/en/kaldi/language_model.txt', '/profiles/en/kaldi/model/data/lang/G.fst.unsorted']' returned non-zero exit status 1.
Traceback (most recent call last):
  File "/usr/lib/rhasspy/.venv/lib/python3.7/site-packages/quart/app.py", line 1821, in full_dispatch_request
    result = await self.dispatch_request(request_context)
  File "/usr/lib/rhasspy/.venv/lib/python3.7/site-packages/quart/app.py", line 1869, in dispatch_request
    return await handler(**request_.view_args)
  File "/usr/lib/rhasspy/rhasspy-server-hermes/rhasspyserver_hermes/__main__.py", line 1313, in api_train
    result = await core.train()
  File "/usr/lib/rhasspy/rhasspy-server-hermes/rhasspyserver_hermes/__init__.py", line 472, in train
    raise TrainingFailedException(reason=asr_response.error)
rhasspyserver_hermes.TrainingFailedException: Command '['fstcompile', '--isymbols=/profiles/en/kaldi/model/data/lang/words.txt', '--osymbols=/profiles/en/kaldi/model/data/lang/words.txt', '--keep_isymbols=false', '--keep_osymbols=false', '/profiles/en/kaldi/language_model.txt', '/profiles/en/kaldi/model/data/lang/G.fst.unsorted']' returned non-zero exit status 1.

I had stumbled across this post (Training issue with Rhasspy 2.5: Missing online.conf - #4 by oggyjack" turning on open transcription seems to fix the issue, but it seems to slow things down. But if i uncheck open transcription i get this error. @synesthesiam is this still an outstanding thing? Your message showed it was corrected so I may be chasing a red herring lol

I have now deleted the entire kaldi folder. Removed ALL slot programs AND removed all sentences other than the get time and get temp that comes by default and still getting an error on training.

rhasspyserver_hermes.TrainingFailedException: Command '['bash', '/usr/lib/rhasspy/.venv/lib/kaldi/egs/wsj/s5/utils/mkgraph.sh', '--self-loop-scale', '1.0', '/profiles/en/kaldi/model/data/lang_unk', '/profiles/en/kaldi/model/model', '/profiles/en/kaldi/model/graph/unk']' returned non-zero exit status 1.

so in short, i can’t get this to train even the base model now. not sure why.

Ok. Update on this. Wiped everything out. When I added the home assistant entities in there is something it didn’t like so the training failed. I had my script that was importing movie titles, same thing. I modified that script to look for a bunch of characters that were causing the training to fail.

Is there a default script somewhere that strips out/cleans up bad characters ect?