Error with rhasspy update 2.5.8 and Larynx

Hi,

When i update my rhasspy master to 2.5.8, i get this error :

Processing ./download/torch-1.6.0-cp37-cp37m-linux_x86_64.whl
Requirement already satisfied: future in ./.venv/lib/python3.7/site-packages (from torch==1.6.0) (0.18.2)
Requirement already satisfied: numpy in ./.venv/lib/python3.7/site-packages (from torch==1.6.0) (1.19.4)
torch is already installed with the same version as the provided wheel. Use --force-reinstall to force an installation of the wheel.
cd "/home/rhasspy/rhasspy/rhasspy-tts-larynx-hermes/larynx/TTS" && \
      "/home/rhasspy/rhasspy/.venv/bin/python" -m pip install  -r requirements.txt && \
      "/home/rhasspy/rhasspy/.venv/bin/python" -m pip install  . && \
cd "/home/rhasspy/rhasspy/rhasspy-tts-larynx-hermes/larynx/TTS/TTS/tts/layers/glow_tts/monotonic_align" && \
      "/home/rhasspy/rhasspy/.venv/bin/python" setup.py install && \
cd "/home/rhasspy/rhasspy/rhasspy-tts-larynx-hermes/larynx" && \
      "/home/rhasspy/rhasspy/.venv/bin/python" -m pip install  -r requirements.txt
/bin/bash: ligne 0 : cd: /home/rhasspy/rhasspy/rhasspy-tts-larynx-hermes/larynx/TTS: Aucun fichier ou dossier de ce type
make: *** [Makefile:168: install-rhasspy] Error 1
rhasspy@rhasspy-master:~/rhasspy$

And yes, i don’t have TTS folder.

Is there a workaround to update to 2.5.8 without larynx ?

Thanks,

Found -_- :

./configure RHASSPY_LANGUAGE=fr \  
   --disable-speech-to-text \ 
     RHASSPY_WAKE_SYSTEM=snowboy \
   --enable-in-place \
   --disable-larynx 
1 Like