I tried to install a fresh rhasspy on a debian buster.
I choose the virtual environnement way.
On my previous version of rhasppy i used following configuration
Speech to Text/kaldi
Text to Speech/picotts
I used configure with following options:
./configure RHASSPY_WAKE_SYSTEM=snowboy RHASSPY_SPEECH_SYSTEM=kaldi RHASSPY_LANGUAGE=fr
When I launch make / make install i have lots of error with version incompatible.
So i ajust my configure to disable component unused.
I use now
./configure RHASSPY_WAKE_SYSTEM=snowboy RHASSPY_SPEECH_SYSTEM=kaldi RHASSPY_LANGUAGE=fr --disable-fuzzywuzzy --disable-wavenet --disable-snips
But i have again error
ERROR: rhasspy 2.5.0 has requirement rhasspy-nlu~=0.2.1, but you'll have rhasspy-nlu 0.2.0 which is incompatible. ERROR: rhasspy 2.5.0 has requirement rhasspy-silence~=0.3.0, but you'll have rhasspy-silence 0.2.0 which is incompatible.
I do not know what is rhasspy-silence and rhasspy-nlu …
Possible to be helped on this ?
I go to rhasspy-silence and rhasspy-nlu and launch make and make install manually
the file “VERSION” on “rhasspy/rhasspy-nlu” content 0.2.1
and 0.3.0 on rhasspy-silence.
how could i force this ?