Download additional files SSL ClientConnectorError

Hi y’all. Im building a Raspberry Pi 4 (4GB) into a van assistant in my van/tiny home. Because Rhasspy is so flexible and can integrate offline voice assistant abilities, it seems the perfect tool for the job. When I played with it before, I was able to get it to work with custom wake words and everything as a test, but now on this new build, I seem to be running into a bunch of issues.

I used the docker install method initially, but because I had some download issues, I ended up downloading the image directly with Portainer, and then running the docker run command - which I would think is equivalent, but I may be wrong.

First sign of something wrong was that the Getting Started Guide can’t be found. And then as I tried to restore my previous setup, or start over, when I need to download files for pocketsphinx, I get this SSL error:

ClientConnectorError: Cannot connect to host ssl:<ssl.SSLContext object at 0xb44844b0> [Temporary failure in name resolution]

I can’t seem to get it to download that way, so I found the en-us poketsphinx github and downloaded the files it was looking for and placed them directly into the profile folder, but still can’t get it to respond to a command.

That returns the error:

RuntimeError: new_Decoder returned -1

I’ve tried recreating the container, starting fresh, disabling pihole… not sure what in my build my be causing the issue.

Raspberry Pi 4 (4GB)
Raspberry Pi OS Desktop
Home Asssistant
Pihole as DNS and DHCP

Also, even when I had it working, my Sony Playstation Eye mic would often not be detected unless I unplugged it and plugged it back in. Anything I can do about that?

This is pointing to a DNS issue. Maybe take a look into the logs of your Pi-hole DNS server? Or temporarily disable Pi-hole, use another DNS server such as and see if you still get the error?

1 Like

Thanks for that clarification, you were right.

You helped me realize that when I turned off DHCP on my Ravpower FileHub, it also meant I couldn’t specify the DNS, even though Pihole was DNS and DHCP, there was no routing of the DNS to the Pihole properly. That explains why disabling Pihole didn’t do anything. Now that I’ve gone back, Rhasspy was able to download the files properly, and take commands again.

Any thoughts on why it inconsistently detects my microphone?

I don’t have experience with the PlayStation Eye. I know that some people are happy with it, others less. If you do a search on this forum, you’ll see a couple of discussions about it, maybe you can find your issue there.

I had the exact same problem, however I solved it differently.
The solution was to add --network host when running the docker image, found on

Once you click “Save Settings”, Rhasspy will restart and try to connect to your MQTT broker. This will fail if you are running Rhasspy inside Docker and trying to connect to localhost! In this case, you must stop Rhasspy (with docker stop) and modify your docker run command like this:

docker run -d -p 12101:12101 \
    --network host \
    --restart unless-stopped \
    -v "$HOME/.config/rhasspy/profiles:/profiles" \
    --device /dev/snd:/dev/snd \
    rhasspy/rhasspy:2.5.0-pre \
    --user-profiles /profiles \
    --profile en

The addition of --network host will allow Rhasspy to connect to services running on your local machine (like mosquitto).