Defining the Rhasspy 'siteId' value

[DEBUG:59880] DialogueManager: {‘entities’: [], ‘intent’: {‘confidence’: 0, ‘name’: ‘’}, ‘raw_text’: ‘’, ‘siteId’: ‘default’, ‘slots’: {}, ‘speech_confidence’: 1, ‘text’: ‘’, ‘time_sec’: 0.0029625892639160156, ‘wakeId’: ‘porcupine’}

This is what I see in the logs. Can the siteId value be defined in the settings on each satellite/client? If so, is it just this simple? What is the correct syntax?


"siteId": {
    "????": "mysite_id"


"??????": {
    "siteId": "mysite_id"

I think you just have to add this to your profile:

    "siteId": "YourSiteID"

Don’t quote me on that, but I think that will work.

1 Like

It’s definitely something like that, but the big question is, into which section does it go, or is it a section unto itself?

If you use mqtt, it’s in the mqtt section.

1 Like

Yeah under mqtt, or if you are not using mqtt, I would say:


In the documentation of the profile settings there is no system sections on the top. And as I understand the docs the site_id is only used by the mqtt settings.

I was wondering about that value, precisely to identify which Rhasspy satellite/client originated a request. That would allow directing text-to-speech payloads back to the correct client device.

  "mqtt": {
    "site_id": "YOURSITEID"

is what sets the Hermes siteId (default is default).

Some systems, like the hermes microphone, support multiple site ids:

  "mqtt": {
    "site_id": "SITE1,SITE2,SITE3"

The first site id is always used when publishing Hermes messages out over MQTT. All of the new Rhasspy services are being coded to:

  1. Be able to listen to multiple site ids
  2. Always pass the request site id out to response messages
  3. Use the first site id when not responding (e.g., a microphone service generating audio frames)

Thank you, @synesthesiam Since I’m not using MQTT in my configuration, setting this value has no effect. I’ll wait patiently until Rhasspy :wink: is released.

In my configurations (docker as Master and 4 Raspberry zeros with virtenv) this works in die gui (browser):

  • Enable mqtt
  • Enter siteid in mqtt Section
  • Disable mqtt
  • Save and restart

Hope, it works für you too.


I use internal MQTT in rahsspy 2.5-pre server/client configuration.
I can’t see siteId in my intent json.
I need to use it in and doesn’t know how to do it…

Anyone with a solution for this?