Default Porcupine wake word not working

Greetings everyone, I have a fresh install of Rhasspy 2.5.9 inside of a Docker container on a Raspberry Pi 3B and I am using a Matrix Voice for the audio input. I am able to successfully recognize intents using the Wake Up button on the web interface, and I can hear the recording playing back through that interface as well. I have not been able to get the Porcupine wake word working. I’m not trying to do anything fancy, but simply use the default wake word. I’m getting the following error message.

[ERROR:2021-03-13 21:17:45,446] rhasspyserver_hermes:
Traceback (most recent call last):
File “/usr/lib/rhasspy/.venv/lib/python3.7/site-packages/quart/”, line 1821, in full_dispatch_request
result = await self.dispatch_request(request_context)
File “/usr/lib/rhasspy/.venv/lib/python3.7/site-packages/quart/”, line 1869, in dispatch_request
return await handler(**request_.view_args)
File “/usr/lib/rhasspy/rhasspy-server-hermes/rhasspyserver_hermes/”, line 826, in api_wake_words
hotwords = await core.get_hotwords()
File “/usr/lib/rhasspy/rhasspy-server-hermes/rhasspyserver_hermes/”, line 887, in get_hotwords
handle_finished(), messages, message_types
File “/usr/lib/rhasspy/rhasspy-server-hermes/rhasspyserver_hermes/”, line 971, in publish_wait
result_awaitable, timeout=timeout_seconds
File “/usr/lib/python3.7/asyncio/”, line 423, in wait_for
raise futures.TimeoutError()

I also tried downloading the Porcupine Raspberry Pi keyword file and putting it in the profile folder, but that also produced the same error. In both cases, the available keywords pulldown is empty.

I believe I have fixed this. Prior to running this version, I was running 2.4.19 I believe. When I got rid of the old Docker container, I didn’t delete the profile directory for Rhasspy. After cleaning this out and starting fresh with a new container for 2.5.9, the Porcupine wake word is working correctly.

Hey @Light

I’m not much familiar with docker so I just want to know how did you delete your rhasspy profile.

What I followed:
I used docker exec -it rhasspy /bin/bash to go inside docker rhasspy image and removed profiles directory which contained en ( English profle in my case) then I re-installed fresh Rhasspy 2.5.9 docker image.

I just want to confirm have I followed proper steps or I missed anything here?

Thanks in advance.

In my case I was following the instructions on which places the profile at:


So, I did sudo rm -Rf on that directory after stop, rm on the container. I did also delete the image, which was probably a waste of time but I just wanted to be sure.

Thanks for your response, hopefully I followed proper steps.