Custom Pronunciation not working

Hi I am totally new to Rhasspy. I finally got it setup with the hassio addon and a raspberry pi as a client. So far it seems communication (even if I still don’t know how and how to use it.) I use intents by adding intens: which btw is nowhere explained nor homeassistant manuals nor here in the project wiki. Well. I started playing around to test my microphone. It worked well so far but then I tried the Pronunciation part in the “words” tab und get this error below:

[ERROR:50903731] PhonetisaurusPronounce: pronounce
Traceback (most recent call last):
  File "/usr/share/rhasspy/rhasspy/pronounce.py", line 53, in in_started
    pronunciations = self.pronounce(message.words, message.n)
  File "/usr/share/rhasspy/rhasspy/pronounce.py", line 120, in pronounce
    self.profile.get(f"speech_to_text.{self.speech_system}.base_dictionary")
  File "/usr/share/rhasspy/rhasspy/profiles.py", line 91, in read_path
    full_path = os.path.join(profiles_dir, self.name, *path_parts)
  File "/usr/lib/python3.6/posixpath.py", line 94, in join
    genericpath._check_arg_types('join', a, *p)
  File "/usr/lib/python3.6/genericpath.py", line 149, in _check_arg_types
    (funcname, s.__class__.__name__)) from None
TypeError: join() argument must be str or bytes, not 'NoneType'
[DEBUG:50903729] PhonetisaurusPronounce: Getting pronunciations for ['kitchen']
[INFO:50900839] quart.serving: 192.168.1.208:50422 POST /api/lookup 1.1 500 57 61616
[ERROR:50900812] __main__: <rhasspy.events.PronunciationFailed object at 0x6fab7190>
Traceback (most recent call last):
  File "/usr/local/lib/python3.6/dist-packages/quart/app.py", line 1471, in full_dispatch_request
    result = await self.dispatch_request(request_context)
  File "/usr/local/lib/python3.6/dist-packages/quart/app.py", line 1519, in dispatch_request
    return await handler(**request_.view_args)
  File "app.py", line 367, in api_lookup
    result = await core.get_word_pronunciations([word], n)
  File "/usr/share/rhasspy/rhasspy/core.py", line 315, in get_word_pronunciations
    assert isinstance(result, WordPronunciations), result
AssertionError: <rhasspy.events.PronunciationFailed object at 0x6fab7190>

Is there anything I can do about this? Or do you need more info how I setup rhasspy on server and cleint ?

Hi @thundergreen, this might be a bug on my end. Do you have a file called base_dictionary.txt in your profile directory? This should have been downloaded automatically.

Also, are you using Pocketsphinx or Kaldi?

I am using Pocketphinx. I am using hassio addon and dunne where this file is supposed to be then

Should be in /share/rhasspy/profiles