Custom pronunciation for some words?

Seriously, my southern drawl is non-existent. Unfortunately, Rhasspy has trouble differentiating between my pronunciation of “off” and “on”. If I had to guess, it’s because I pronounce them “awff” and “awn” rather than a more Bostonian “ahff” and “ahn”.

Is this something I can override in the dictionary, with a custom phoneme specification?

1 Like

Yep. You can use the Words tab or edit custom_words.txt in your profile directly (in the kaldi directory if you’re using Kaldi). The table in the Words tab will give you a hint about the available phonemes, and you can look up the existing pronunciation to see how it differs.

By default, your custom words will be merged with base_dictionary.txt and only used words are copied into dictionary.txt. I’ve considered adding an option to make your custom words override the base words. Let me know if you end up needing this.


BTW did you try to talk right to the mic?
I had the same issue caused by my mic low volume. Rhasspy just can’t distinguish ‘off’ from ‘on’ when my voice is too quiet

Thanks for that! I typically talk from across the room, but it’s a clear path and the microphone is nicely sensitive. I just tweaked the sensitivity up a few days ago, and had to back it down a few times since then, or it was activating from room noise. :frowning:

Just an update. Still having problems, despite trying three or four alternate phonemic pronunciations. Used the alsamixer -c 1 command to boost the microphone input level, and observed the logs on my Rhasspy satellite/client using the Jabra 410 USB speaker/mic.

[DEBUG:61438092] WebSocketObserver: {"entities": [], "intent": {"confidence": 0, "name": ""}, "raw_text": "turn all brass lamp", "siteId": "default", "slots": {}, "speech_confidence": 1, "text": "turn all brass lamp", "time_sec": 0.0046045780181884766, "wakeId": "porcupine"}

Rhasspy is hearing/understanding ‘all’ when I say ‘on’. :skull_and_crossbones:

Can you remind me if you’re using Pocketsphinx or Kaldi?

Pocketsphinx on the Home Assistant ‘server’ node.

I have a sneaking suspicion the microphone on this particular Jabra Speak 410 USB speaker/mic may be an issue. I’m going to swap it with the upstairs unit and see what may or may not change.

1 Like

Nope. After swapping the Jabra unit, and tweaking the mic/input level up/down, it’s still just not recognizing speech nearly well enough. I do believe I’m about to try a ReSpeaker USB 4-mic array, instead. But then I’ll have to manage a separate speaker, or use two different devices for microphone and speaker. Yeesh. :woozy_face:

Do you get any better results from Kaldi? Don’t worry if it’s too slow right now. It’ll get a big speed bump in the near future.

1 Like

Haven’t really tried Kaldi, yet. Might give it a shot tomorrow. I spent today hooking up a new ESPHome fireplace control (works great) and defining sentences and automations for it. That’s when my downstairs wifi/router/ap died. :frowning: Very frustrating afternoon with so many devices unable to connect to their network.

:frowning: Sorry to hear that

Finally got all the wifi/mesh issues worked out Sunday afternoon. This morning, switched the ‘server’ instance of Rhasspy speech-to-text from pocketsphinx to kaldi. So far, the results are MUCH better. :slight_smile:

I should also mention, after being a bit of a touchy subject, the WAF has gone back up tremendously. :wink:

1 Like