Change the Wake WAVs

Hi, I try to change the default sounds for “Wake” “Recorded” and “Error”. I got trouble with the Wake sound. I checked the original beep_hi.wav. 44.1kHz Stereo 16 Bit. Length about 1 Sec.
I tried to use another WAV that sounds a little bit more pleasant. I used the same parameters and length of recording. I use Snowboy Wake detection with the “Snowboy” Wakeword (Default). I upload the WAV file to my profiles, and add it to the settings. When I say the wake word my new sound wav is played. Good so far. If I then say my voice phrase it seems my first word is not recognized and therefore the whole sentence is not.
Is there any trick here I miss?

Hello Volker and welcome to the Rhasspy community!! :slight_smile:

I’ve noticed this as well. I simply prefix most of my requests with ‘please’ (bitte?) as a throwaway word and it works fairly well.

You might also try setting command.webrtcvad.throwaway_buffers to zero and see if that helps. In your profile.json:

  "command": {
    "webrtcvad": {
      "throwaway_buffers": 0

Looks like the throwaway buffers is what I needed.Thanks

1 Like