Can't get Wake Word and sound output working

Hi Guys,

First of all thanks for the creators putting so much effort in this project.
I’m very new to Rhasspy so please bear with me. I tried to find some information in the docs and in the forum but it seems that I might miss something essential. Everything is setup according to the documentation (hopefully :thinking:).

Here is my setup:

  • Debian 9 in a VM.
  • running Rhasspy 2.5.0
  • Docker Setup
  • German Profile


I was able to create some sentences and also test them using the Wake Button from the GUI. It’s working on both the Satellite and the Master. However I’m a bit lost configuring the correct sound output on the satellite . I have a 3.5mm headset connected directly to the MicHat2 and can’t hear anything. I would expect to get some audio feedback when pressing the wake button or at least some audio output when using the text to speak feature. But there is nothing. Also I can’t hear anything using the play recording button so I can’t say how good the audio input is.
On the other hand the Wake Word detection doesn’t seem to respond. I tried several Wake Words without any luck. I first used the German profile but read here in the forum to better use English profile for the satellite. Unfortunately that didn’t help.
Where do I find the logfiles so I can provide them when needed?

Thanks in advance.
Best regards Marc.

regarding the audio issue:
Did you select the correct audio output ?
Does the audio output on the pi zero w work with other applications? (like if you just use aplay with a audio file from the commandline)
in your config CARD=headphone is selected and atleast for me the 2mic hat is called CARD=seeed2micvoicec .

regarding the issue with the wakeword:
Did you already try setting the sensitivity for snowboy to something like 0.8 or higher?

1 Like

Thanks @moqart for your response.

I’ve tried several but probably not the correct one. Now it works. :+1:

yes - I used arecord -f cd -Dhw:1 | aplay -Dhw:1 command according to respeaker docs and got correct readback.

I noticed that after changing the (audio?) settings i had to restart the container - otherwise I got some timeouts when using e.g. tts. I’ll further check that tomorrow.

I also changed some settings for snowboy including the sensitivity and now it seems to work. :thinking: :+1: :+1: :+1: