Cannot install seeed-voicecard driver

I have hassio on a raspberry pi 3B en installed the Rhasspy Assistant add-on.
In the settings i cannot select the seeed-voice-card, at Input only Default is available and at Output is Default and Built-in Audio Digital Stereo (IEC958) available:


In the Terminal the results of the commands aplay -l and arecord -l :

To install the driver for the seeed-voicecard i have to type the following commands:

git clone
cd seeed-voicecard
sudo ./

After the last command I get errors:


There is no /boot map:


Can you help me?
Jan Verhaar

As far as I understood you you are running hassOS?
I don’t use this setup myself but I’ve seen a lot of people having trouble to install some other audio devices on hassOS.

Maybe you should think about running just Raspbian Buster alone and all your Home Assistant stuff as docker setup. Would be much easier for you to add addtional stuff.

Probably there are some command flags to enable this inside the hassio addon as well. I don’t know.

It seems you run HAssOS, that is not a standard distrubution.

I suggest installing raspbian and then the seeed-voicecard.
Then your arecord -l will output the card.

If that works, install Home Assistant this way:

More precise for you (after you have installed docker an such):

curl -sL “” | bash -s – -m raspberrypi3

You can install the addon after that.

Thanks for your advice, I will do that.

I installed Raspbian, Home Assistant end Rhasspy with succes.
Now I am going on with setting up the system.

1 Like

I like the cards and price of the Respeaker 4 Pi cards but boy do those drivers suck.
They even seem to fall down on vanilla raspbian when all you try to do is install pulseaudio.
If you have got them running then you have a really great low cost card, but boy the drivers suck.

1 Like