Basic (silly ?) configuration with hassio addon

Hello,

Until now, I fiddled with home assistant (based on raspbian) with programs I installed manually, so no problems whatsoever with network or anything like that.

My setup : - raspberry pi 4 with hassio image, and mosquitto + rhasspy addons
- raspberry pi zero with raspbian and rhasspy-satellite (let’s focus on the RPI4 for the moment ^^)

I wanted to try hassio because rhasspy had an addon too, but… I don’t understand how I’m supposed to connect rhasspy to home assistant, nor to mosquitto
I don’t really know what address to use for mqtt and hass servers because it’s docker-based (no 127.0.0.1 nor localhost works)
Tried internal docker adresses (like 172.30.32…) but it fails too

Doc mentions integration with hass and websockets, but doesn’t give much more information.

Is the MQTT connection mandatory ? logs keep spitting out connection failures even if I try to disable mqtt
What am I supposed to put in the MQTT and hass host fields when everything is on a single hassio image ?

MQTT is not mandatory.
If you have a Mic and Speaker on the Pi4, you can leave it disabled.

My setup :

RPI4 : No mic, No Spkr and hassio + rhasspy addon + moquitto addon
Rpi zero : Respeaker hat 2, raspbian buster with rhasspy-satellite from : https://github.com/rhasspy/rhasspy-satellite

I do need MQTT because I want the RPI4 to do the speech and intent recognition.
It appears that the problem comes from the fact that mosquitto and rhasspy aren’t configured to use the same network bridge.
Tried to find my way with portainer with no luck so far.
I checked, and everything seems fine : those containers are on the same bridge

Logs give this on and on :
[DEBUG:506997] HermesMqtt: Reconnecting in 5 second(s)
[ERROR:506996] HermesMqtt: connecting
Traceback (most recent call last):
File “/usr/share/rhasspy/rhasspy/mqtt.py”, line 126, in do_connect
ret = self.client.connect(self.host, self.port)
AttributeError: ‘NoneType’ object has no attribute ‘connect’

Edit : it’s fixed now, just tried to put again the container’s adress

A sorry, misread.
Yes, then you need MQTT.
Change te setting for MQTT to the IP of you RPI4, that will make Rhasspy connect to the Mosquitto addon.Also, user and password should be filled with the user and password of a HomeAssistant user if the Mosquitto addon config anonymous is set to false (default)