After set mqtt external, can`t access to Dashboard anymore

Hello there,

Im new here =)

First, i am more a noob who trys some stuff.

Raspberry pi 4 with:
Iobroker → mqtt broker ( (working!)

Raspberry pi 3b with:

I did folow the Tutorial and did set up everything, steps with node-red did all work (just changed localhost with the ip)
then it did come to mqtt, i did change to external and did enter the IP and port → Save. And then the Page did not reload and can`t access anymore.

Docker log from Rhasspy Container says always:

[DEBUG:2022-05-26 13:46:11,442] rhasspyserver_hermes: Connecting to (retries: 0/10)

Can anyone explain why this is happen? Do you need more information? And what can i do now?

Maybe some one can help me, thx =)

Try to set up some credentials and use those. I think there was an issue with that

But how, when i can`t access now to the dashboard?

Can you still access the Rhasspy-Pi on the command line? If so, look in your profile directory for the file “profile.json”. This is where all your entries from the Web-UI are saved.

As you are using docker, you should have a persistent volume for your config. In my case this is RHASSPY-ROOT/config/profiles/de/profile.json.

In this file you have a section for the MQTT settings:

    "mqtt": {
        "enabled": "true",
        "host": "url_from_mqtt_broker",
        "password": "your_mqtt_password",
        "site_id": "your_siteId",
        "username": "username_you_set_in_your_mqtt_broker"

This should get you going. :slight_smile:

1 Like

Thank you! i did edit to “false” and now i can open the Dashboard again. But what can i change so i can use mqtt? and use the dashboard?

for me that sounds strange enable mqtt and then can`t access to the dashboard anymore?

EDIT: i did just figure out why, i swaped the password and the ussername for mqtt.

so now it works, mqtt set up und can access to the dashboard!

But, still intresting that this setting kills the dashboard conection.

That shouldn’t be the case, so there must be an error along the way. :slight_smile:

As @romkabouter said, try it with credentials for the connection to the mqtt broker. Your error message seems to point in that direction, too. Setup a user and password in your mqtt broker to use, and add these credentials to your Rhasspy config to use as the external mqtt.

This should look like the quote I posted above, I’m using mosquito as my external broker.

On a side note, if you have problems with mqtt, checkout the tool MQTT-Explorer to get an overview what is send around in your mqtt network. With that tool you can as well check if some things won’t do what you expect them to do, eg. a wrong topic or something like that. You should see as well, if connections to your mqtt broker work, and if topics are sent and received.

EDIT: Great you got it working! :slight_smile:

Yeah thank you! I got this part. I just did write the password as ussername and also the other way. XD.

But now i figured out an other problem i guess :thinking:

when enebaling mqtt, i dont see my microphone selectet in the settings anymore… why? also i cant refresh, that gives me a TimeoutError… :thinking: do you maybe know what that problem is?

It seems, there is something wrong with your installation itself. Normally all these things (and settings) are handled inside the docker container, or at least are configured through that container.

I have a guess, but can’t say without more information. I’d speculate that you haven’t set your persistent volumes when starting docker, and maybe there is something wrongly configured with the “device” section for the docker container as well.

How exactly did you install the Rhasspy-Pi? But before you answer, it might be a good idea to open up a new thread for this/these problems. People tend to skip threads, that already have a solution. Just open up a new thread. :slight_smile: