2.5.10 can't train anymore with unknown words

Hi,
This morning I did adjusted a few sentences. trained, worked

I just set a new word in words tab, can’t train anymore. Cancelling the modification, deleting the file, saving with empty words, can’t train anything.

Any idea ?

[ERROR:2021-05-02 16:30:33,998] rhasspyserver_hermes: Command '['bash', '/usr/lib/rhasspy/.venv/lib/kaldi/egs/wsj/s5/utils/prepare_lang.sh', '/profiles/fr/kaldi/model/data/local/dict', '<unk>', '/profiles/fr/kaldi/model/data/local/lang', '/profiles/fr/kaldi/model/data/lang']' returned non-zero exit status 1.
Traceback (most recent call last):
  File "/usr/lib/rhasspy/.venv/lib/python3.7/site-packages/quart/app.py", line 1821, in full_dispatch_request
    result = await self.dispatch_request(request_context)
  File "/usr/lib/rhasspy/.venv/lib/python3.7/site-packages/quart/app.py", line 1869, in dispatch_request
    return await handler(**request_.view_args)
  File "/usr/lib/rhasspy/rhasspy-server-hermes/rhasspyserver_hermes/__main__.py", line 1306, in api_train
    result = await core.train()
  File "/usr/lib/rhasspy/rhasspy-server-hermes/rhasspyserver_hermes/__init__.py", line 471, in train
    raise TrainingFailedException(reason=asr_response.error)
rhasspyserver_hermes.TrainingFailedException: Command '['bash', '/usr/lib/rhasspy/.venv/lib/kaldi/egs/wsj/s5/utils/prepare_lang.sh', '/profiles/fr/kaldi/model/data/local/dict', '<unk>', '/profiles/fr/kaldi/model/data/local/lang', '/profiles/fr/kaldi/model/data/lang']' returned non-zero exit status 1.
[ERROR:2021-05-02 16:30:33,997] rhasspyserver_hermes: AsrError(error="Command '['bash', '/usr/lib/rhasspy/.venv/lib/kaldi/egs/wsj/s5/utils/prepare_lang.sh', '/profiles/fr/kaldi/model/data/local/dict', '<unk>', '/profiles/fr/kaldi/model/data/local/lang', '/profiles/fr/kaldi/model/data/lang']' returned non-zero exit status 1.", site_id='salle', context=None, session_id='2d12a5a9-6e00-444e-804a-6fdc436fa79b')
[DEBUG:2021-05-02 16:30:33,995] rhasspyserver_hermes: Handling AsrError (topic=hermes/error/asr, id=07317012-de70-4429-95e6-f42eee7aa8be)
[DEBUG:2021-05-02 16:30:31,423] rhasspyserver_hermes: Handling NluTrainSuccess (topic=rhasspy/nlu/salle/trainSuccess, id=07317012-de70-4429-95e6-f42eee7aa8be)
[DEBUG:2021-05-02 16:30:30,975] rhasspyserver_hermes: Publishing 25467 bytes(s) to rhasspy/nlu/salle/train
[DEBUG:2021-05-02 16:30:30,975] rhasspyserver_hermes: -> NluTrain
[DEBUG:2021-05-02 16:30:30,961] rhasspyserver_hermes: Publishing 25467 bytes(s) to rhasspy/asr/salle/train
[DEBUG:2021-05-02 16:30:30,960] rhasspyserver_hermes: -> AsrTrain

Ok

Slot tab : I delete everything, save -> train fail
restart rhasspt : train ok
slot tab, confirm guesses, train fail

Didn’t add any new words in sentences/slots …

Exact same thing on another rhasspy 2.5.10 for test.
As soon as I go into words tab and edit it or applys guesses, traning fail after that

EDIT:

Did a reset of sentences / slots, started to add a few, all works until training hit some unknown words, then I confirm guesses, and training fails …

Ok, seems it came from a manual added one (I though wasn’t there anymore):

lumiere l y m j ER

ER should be E R

Maybe an exception with error message like “Misspelled word found in unknown word” could help ?