Version 2.4.15 Release

I’ve pushed version 2.4.15 to Docker and the Hass.IO repository. This release mostly contains bugfixes, but there are a few new features to report.

  • Preliminary support for Pi Zero
    • I’ve successfully run Rhasspy on a Pi Zero (PS3 eye USB mic)!
    • Only the virtual environment option is currently supported (does anyone know of a good armv6l Docker image?)
    • Kaldi is not working yet, so only profiles with Pocketsphinx will work
  • Play an “error” sound when an intent isn’t recognized
    • See the “Intent Recognition” section in Settings to disable this
    • Customize the sound in the “Sounds” section
  • Add _text and _raw_text slots to Home Assistant events
    • Lets you access the ASR transcription in your HA automations
  • Disable wake word detection while text-to-speech is speaking
    • See “Text to Speech” section in the Settings tab to re-enable
  • Using json5 to parse profile.json because I keep forgetting dangling commas
  • Lots of small fixes
    • ngrammake errors during training
    • Pop sound with picotts
    • Try to recover from failure to initialize PyAudio
    • Don’t open/close microphone every wake/intent cycle

Most of the work since this last Rhasspy version has been on breaking it up into individual services. Once that’s complete, it will be easier to run pieces of Rhasspy across multiple devices. And, hopefully, it will be easier for developers to contribute fixes or new features :slight_smile:



Nice work again !

Can confirm no more scratch with picotts.
No more problem either with tts activating wakeword detection :+1:

One strange thing anyway, my training usually took around 8sec with 2.4.14, now with same intents/slots it take 1.3sec :astonished:

I’ve run my rhasspy batch tester and still 100% match. Is such performance boost was expected ?

1 Like

Many, many gracious thanks!! Rhasspy is the perfect solution for those of us who prefer in-home F/OSS solutions to voice control. Why depend on the cloud and someone else’s service? There is no reason, unless you want Amazon or Google or Facebook knowing all your daily comings and goings.


Hello everyone,

I am Thomas from Germany and an absolute beginner in Rhasspy. Right now i am working with the version 2.4.
But what is the easiest way to update to the current version instead of set up complete new one?

Thanks in advance and greetings,

docker pull synesthesiam/rhasspy-server:latest

Typically, you’d pull the newest version of the docker image, then restart your docker container using it.

Thanks! I’ve added update instructions now to each Rhasspy installation method in the docs.


I wasn’t expecting that, but I’ll take credit for it :wink:

My guess is that there was something previously preventing the caching mechanism from working. I wonder if running the “Clear Cache” training would take 8 sec again.

Hi, i´ve tried to setup Rhasspy on a pi zero. After setting the variables no_kaldi in and in true, I´ve got no erros because of no kaldi support. But then, I´ve got the error “unexpected EOF in archive”. Mayby theres a bug in the archive or something went wrong trough the compression?

Downloading the file again fixed the problem.

1 Like

OK, good to know :+1:

I really need to do some kind of integrity check on the downloaded files. Partial downloads appear to be more frequent then I’d originally considered.

Especially for rpi zero where the wifi adapter is a bit weak :frowning: …BTW any progress on the rpi Zero support (armv6l)

After installing Rhasspy on my Pi 3b+ and also on my pi zero, i´ll get this the error “compressed file ended before the end-of-stream marker was reached”. I´ve installed rhasspy out of docker on the pi3 and in the virtual environment on the pi zero. Seems like this is a problem of the new version, because some days ago with 2.4.14, everything worked fine.