Help for a Newbie on Installing Rhasspy

Hello. I’m new here. I’m going to be ambitious and see if I can integrate Rhasspy with Hubitat.

I’ve setup a new RPI 4, and I’ve downloaded the appropriate file: rhasspy_arm64.deb
However, I just can’t seem to do the install:

Is there something else that I should be doing?

you could use a premade image for your pi

Where did you download the .deb file to ?

Maybe its because i’m still new at linux, but I try to download into my home directory and let the installer put the package at root or wherever is appropriate.

Other than checking that you have the correct path to the file, I have nothing. I also followed the Rhasspian Debian install instructions for my satellites, and it worked for me.

  1. I downloaded the file and put it into the rhasspy folder.
  2. I am using a rpi 4b, with a fresh install of the os (arm64 architecture).
  3. the downloaded file is called rhasspy_arm64.deb

Sorry to belabour the point, but it’s a mistake I’ve made a couple of times, and in case you are new to linux like me …

Did you create the rhasspy folder in root directory (sudo mkdir /rhasspy) or in your home directory (mkdir rhasspy) ?

Your original post is looking in the /rhasspy folder in the root directory (because of the initial “/” in the path/filename).
If (like me) you created the rhasspy folder in your home folder you should place a dot in front (install ./rhasspy/rhasspy_2.5.11_arm64.deb) to indicate that the path starts from the current directory.

I note also that your last post (point 3) mentions a different file name, which I guess means that you are trying again to download and install.

ls -l rhasspy_arm64.deb
-rw-r–r-- 1 root root 223022580 Dez 7 10:31 rhasspy_arm64.deb


sudo apt install rhasspy_arm64.deb

You have to give the full path.
/home/pi/rhasspy_arm64.deb maybe?


(By the way, I wanted to thank you for taking the time to help. Much appreciated).
Perhaps this is because I’m using bullseye, instead of buster?

sudo apt install /home/pi/rhasspy_arm64.deb

it’s right. You are missing the libgfortan4 package, which is not available for Bullseye. The following post might help:
(amd64 needs to be replaced with arm64 and it will take you a lot of time. )

Dear jens-schiffke, I’ve followed the instructions you outlined in your linked post, but I’m seeing this error:
dpkg-deb: error: parsing file ‘tmp/DEBIAN/control’ near line 2: missing ‘Package’ field
I’ve run through it a couple of time to make sure I’m not missing anything, but still get the same error. Any help would be very much appreciated! (and jtmpush18, sorry for hijacking your thread, but thought you’d end up in the same place as I am).

sorry, sed is wrong

sed -i 's/libgfortran4/libgfortran5/' ./tmp/DEBIAN/control

consider installing via the docker, it is a much smoother experience. You would not have to worry about the issues during direct install

  1. Install the docker
    curl -sSL | sh
  2. Install the rhasspy as a docker container - follow the instructions in the site
    Installation - Rhasspy