Help Changing Porcupine Wake Word

I have found other Porcupine wake words, and thought it would be as easy as just dropping them in the porcupine folder and point the settings to it, but that did not seems to work for me. Does anyone know is there some other setting(s) that I have to change or add in order to use the pre-made wake word on Picovoice Github page, thanks.

Hi @TinyDoT
What hardware do you use? Are you sure you have downloaded wake word for your system?

I too tried the downlloads for all the porcupine raspberry pi ‘alternative’ wakeword…I really wanted the “hey pico” sadly no instructions to change filename or even where to put it in the porcupine directory!!! I gave up .
The only way I could get it working for me was to use a Pi Zero with snips wakeword installed and work to Rhasspy Pi using mqtt.

Hi @frkos

I have Rhasspy install on a laptop with virtualbox with ubuntu, so I downloaded the wake word for linux .

Hey @ED_Snowden

How did you use the snips wake word?

I have successfully tried many wake up words for Linux, without any problem. You need to ensure you download the correct file for your system. And also control that the file was downloaded as binary and not as text.
then copy that file to this folder /usr/share/hassio/share/rhasspy/profiles/en/porcupine
if you are using linux (that is in my situation)

In this post from duch (thanks duch !) Respeaker 2 Hat - Buster - Rhasspy + HA as service install + picotts + snips wakeword

[optional] install Snips wakeword - we don’t need/want all Snips platform

sudo bash -c 'echo "deb stable main" > /etc/apt/sources.list.d/snips.list'
sudo apt-key adv --fetch-keys
sudo apt update
sudo apt install mosquitto mosquitto-clients snips-satellite snips-hotword-model-heysnipsv4

It works for me !

Thanks majB. I tried that. But life is too short. I gave up. The githubporcupine raspberry pi page was also confusing to me with ‘download’ sometimes and then ‘raw’ I created files with the 'raw but I just got angry.
Ths Pi Zero works fine with “hey-snips” Suits me fine. I really liked Snips. Such a shame.

I’m using rpi 3b+ and just downloaded heypico file

I renamed it to heypico.ppn (I don’t like spaces in filenames :nerd_face:) and placed it here profiles/en/porcupine
Then set it in Rhasspy settings porcupine/heypico.ppn
Rebooted rhasspy and it works!

Tip: Are you sure you downloaded file properly? For example open my link, right click on Raw button and choose Save link as...

Thank you guys for everything. The big take away is you have to download the file properly. And, with doing that I am up and working.

@ED_Snowden I am going to definately give the snips wake word a ago, because I created a custom wake word that I used for snips, and not have to change to a new one would be awesome.

So, thanks again guys.